GHSA-gggp-gh2p-996x

Suggest an improvement
Source
https://github.com/advisories/GHSA-gggp-gh2p-996x
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/02/GHSA-gggp-gh2p-996x/GHSA-gggp-gh2p-996x.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-gggp-gh2p-996x
Aliases
Published
2022-02-19T00:01:27Z
Modified
2023-11-08T04:07:38.005916Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Path Traversal in LemMinX
Details

A flaw was found in LemMinX in versions prior to 0.19.0. Cache poisoning of external schema files is possible due to directory traversal.

References

Affected packages

Maven / org.eclipse.lemminx:lemminx-parent

Package

Name
org.eclipse.lemminx:lemminx-parent
View open source insights on deps.dev
Purl
pkg:maven/org.eclipse.lemminx/lemminx-parent

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.19.0