GHSA-gjvc-55fw-v6vq

Suggest an improvement
Source
https://github.com/advisories/GHSA-gjvc-55fw-v6vq
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/08/GHSA-gjvc-55fw-v6vq/GHSA-gjvc-55fw-v6vq.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-gjvc-55fw-v6vq
Aliases
Published
2023-08-21T20:28:03Z
Modified
2024-02-16T08:05:24.353339Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Wallabag user can delete own API client unintentionally
Details

Description

wallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily delete API key via /developer/client/delete/{id}

This vulnerability has a CVSSv3.1 score of 6.5.

You should immediately patch your instance to version 2.6.3 or higher if you have more than one user and/or having open registration.

Resolution

This action is now doable only via POST method, which ensures that we can't do it via a 3rd-party website.

Credits

We would like to thank @tht1997 for reporting this issue through huntr.dev.

Reference: https://huntr.dev/bounties/5ab1b206-5fe8-4737-b275-d705e76f193a/

References

Affected packages

Packagist / wallabag/wallabag

Package

Name
wallabag/wallabag
Purl
pkg:composer/wallabag/wallabag

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0-alpha.1
Fixed
2.6.3

Affected versions

2.*

2.0.0-alpha.1
2.0.0-alpha.2
2.0.0-beta.1
2.0.0-beta.2
2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.1.0
2.1.1
2.1.2
2.1.3
2.1.4
2.1.5
2.1.6
2.1.6.1
2.2.0
2.2.1
2.2.2
2.2.3
2.3.0
2.3.1
2.3.2
2.3.3
2.3.4
2.3.5
2.3.6
2.3.7
2.3.8
2.4.0
2.4.1
2.4.2
2.4.3
2.5.0
2.5.1
2.5.2
2.5.3
2.5.4
2.6.0
2.6.1
2.6.2

Database specific

{
    "last_known_affected_version_range": "<= 2.6.2"
}