GHSA-gm8c-w9cm-c445

Suggest an improvement
Source
https://github.com/advisories/GHSA-gm8c-w9cm-c445
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/09/GHSA-gm8c-w9cm-c445/GHSA-gm8c-w9cm-c445.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-gm8c-w9cm-c445
Aliases
Published
2022-09-21T00:00:46Z
Modified
2023-11-08T04:09:36.449977Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Microweber vulnerable to HTML Injection in create tag functionality
Details

HTML injection attack is closely related to Cross-site Scripting (XSS). HTML injection uses HTML to deface the page. XSS, as the name implies, injects JavaScript into the page. Both attacks exploit insufficient validation of user input. A patch is available on commit f20abf30a1d9c1426c5fb757ac63998dc5b92bfc and is anticipated to be part of version 1.3.2.

References

Affected packages

Packagist / microweber/microweber

Package

Name
microweber/microweber
Purl
pkg:composer/microweber/microweber

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3.2

Affected versions

0.*

0.9.346
0.93
0.931
0.934
0.951

1.*

1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.1

v1.*

v1.2.3
v1.2.4
v1.2.5
v1.2.6
v1.2.7
v1.2.8
v1.2.9
v1.2.10
v1.2.11
v1.2.12
v1.2.13
v1.2.14
v1.2.15
v1.2.16
v1.2.17
v1.2.18
v1.2.19
v1.2.20
v1.2.21
v1.3.0
v1.3.1

Database specific

{
    "last_known_affected_version_range": "<= 1.3.1"
}