GHSA-gvxv-p9rv-gmcg

Suggest an improvement
Source
https://github.com/advisories/GHSA-gvxv-p9rv-gmcg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-gvxv-p9rv-gmcg/GHSA-gvxv-p9rv-gmcg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-gvxv-p9rv-gmcg
Aliases
Published
2022-06-17T21:46:28Z
Modified
2023-12-06T01:02:22.224591Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
brotkrueml/typo3-matomo-integration vulnerable to Cross-Site Scripting
Details

The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

References

Affected packages

Packagist / brotkrueml/typo3-matomo-integration

Package

Name
brotkrueml/typo3-matomo-integration
Purl
pkg:composer/brotkrueml/typo3-matomo-integration

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3.2

Affected versions

v1.*

v1.0.0
v1.0.1
v1.1.0
v1.2.0
v1.3.0
v1.3.1