GHSA-gxm5-jrrf-5c4v

Suggest an improvement
Source
https://github.com/advisories/GHSA-gxm5-jrrf-5c4v
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-gxm5-jrrf-5c4v/GHSA-gxm5-jrrf-5c4v.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-gxm5-jrrf-5c4v
Aliases
Published
2022-05-24T22:00:02Z
Modified
2024-02-16T08:21:10.062689Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Jenkins Artifactory Plugin missing permission check
Details

Jenkins Artifactory Plugin does not perform permission checks on a method implementing form validation. This allows users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Additionally, this form validation method does not require POST requests, resulting in a cross-site request forgery vulnerability.

As of publication of this advisory, no release containing a fix is available.

References

Affected packages

Maven / org.jenkins-ci.plugins:artifactory

Package

Name
org.jenkins-ci.plugins:artifactory
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/artifactory

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
3.2.2

Affected versions

2.*

2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.1.0
2.1.1
2.1.2
2.1.3
2.1.4
2.1.5
2.1.6
2.1.7
2.1.8
2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.2.6
2.2.7
2.3.0
2.3.1
2.4.0
2.4.1
2.4.2
2.4.3
2.4.4
2.4.5
2.4.6
2.4.7
2.5.0
2.5.1
2.6.0
2.7.0
2.7.1
2.7.2
2.8.0
2.8.1
2.8.2
2.9.0
2.9.1
2.9.2
2.10.0
2.10.1
2.10.2
2.10.3
2.10.4
2.11.0
2.12.0
2.12.1
2.12.2
2.13.0
2.13.1
2.14.0
2.15.0
2.15.1
2.16.0
2.16.1
2.16.2

3.*

3.0.0
3.1.0
3.1.1
3.1.2
3.2.0
3.2.1
3.2.2