GHSA-h4w9-6x78-8vrj

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-h4w9-6x78-8vrj/GHSA-h4w9-6x78-8vrj.json
Aliases
  • CVE-2022-31035
Published
2022-06-21T20:04:34Z
Modified
2022-06-21T20:04:34Z
Details

Impact

All unpatched versions of Argo CD starting with v1.0.0 are vulnerable to a cross-site scripting (XSS) bug allowing a malicious user to inject a javascript: link in the UI. When clicked by a victim user, the script will execute with the victim's permissions (up to and including admin).

The script would be capable of doing anything which is possible in the UI or via the API, such as creating, modifying, and deleting Kubernetes resources.

Patches

A patch for this vulnerability has been released in the following Argo CD versions:

  • v2.4.1
  • v2.3.5
  • v2.2.10
  • v2.1.16

Workarounds

There are no completely-safe workarounds besides upgrading.

Mitigations:

  1. Avoid clicking external links presented in the UI. Here is an example of an Application node with an external link:

    Application node in the Argo CD UI with an external link

    The link's title is user-configurable. So even if you hover the link, and the tooltip looks safe, the link might be malicious. The only way to be certain that the link is safe is to inspect the page's source.

  2. Carefully limit who has permissions to edit resource manifests (this is configured in RBAC).

References

Credits

Disclosed by ADA Logics in a security audit of the Argo project sponsored by CNCF and facilitated by OSTIF. Thanks to Adam Korczynski and David Korczynski for their work on the audit.

For more information

References

Affected packages

Go / github.com/argoproj/argo-cd

github.com/argoproj/argo-cd

Affected ranges

Type
SEMVER
Events
Introduced
1.0.0
Fixed
2.1.16

Affected versions

Database specific

{
    "last_known_affected_version_range": "<= 1.8.7"
}

Go / github.com/argoproj/argo-cd/v2

github.com/argoproj/argo-cd/v2

Affected ranges

Type
SEMVER
Events
Introduced
0
Fixed
2.1.16

Affected versions

Go / github.com/argoproj/argo-cd/v2

github.com/argoproj/argo-cd/v2

Affected ranges

Type
SEMVER
Events
Introduced
2.2.0
Fixed
2.2.10

Affected versions

Go / github.com/argoproj/argo-cd/v2

github.com/argoproj/argo-cd/v2

Affected ranges

Type
SEMVER
Events
Introduced
2.3.0
Fixed
2.3.5

Affected versions

Go / github.com/argoproj/argo-cd/v2

github.com/argoproj/argo-cd/v2

Affected ranges

Type
SEMVER
Events
Introduced
2.4.0
Fixed
2.4.1

Affected versions

2.*

2.4.0