GHSA-h5g9-2p35-54c7

Suggest an improvement
Source
https://github.com/advisories/GHSA-h5g9-2p35-54c7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/05/GHSA-h5g9-2p35-54c7/GHSA-h5g9-2p35-54c7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-h5g9-2p35-54c7
Aliases
Published
2023-05-31T15:30:18Z
Modified
2024-02-16T08:13:07.858993Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
nilsteampassnet/teampass vulnerable to cross-site scripting
Details

Cross-site Scripting (XSS) - Stored in GitHub repository nilsteampassnet/teampass prior to 3.0.9. This enables an attacker to inject malicious code into a shared folder, which can then be executed by other users who have access to the folder.

References

Affected packages

Packagist / nilsteampassnet/teampass

Package

Name
nilsteampassnet/teampass
Purl
pkg:composer/nilsteampassnet/teampass

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.9

Affected versions

2.*

2.1.21
2.1.26
2.1.27

3.*

3.0.0
3.0.0.10
3.0.0.11