GHSA-h6qv-f5gf-8gcf

Suggest an improvement
Source
https://github.com/advisories/GHSA-h6qv-f5gf-8gcf
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/06/GHSA-h6qv-f5gf-8gcf/GHSA-h6qv-f5gf-8gcf.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-h6qv-f5gf-8gcf
Aliases
  • CVE-2021-21654
Published
2021-06-16T17:29:35Z
Modified
2024-02-16T08:16:39.925460Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N CVSS Calculator
Summary
Missing Authorization in Jenkins P4 plugin
Details

Jenkins P4 Plugin 1.11.4 and earlier does not perform permission checks in multiple HTTP endpoints, allowing attackers with Overall/Read permission to connect to an attacker-specified Perforce server using attacker-specified username and password.

Jenkins P4 Plugin 1.11.5 requires Overall/Administer for the affected HTTP endpoints.

References

Affected packages

Maven / org.jenkins-ci.plugins:p4

Package

Name
org.jenkins-ci.plugins:p4
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/p4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.11.5

Affected versions

1.*

1.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.0.8
1.0.9
1.0.10
1.0.11
1.0.12
1.0.13
1.0.14
1.0.15
1.0.16
1.0.17
1.0.20
1.0.21
1.0.22
1.0.23
1.1.0
1.1.1
1.1.2
1.1.3
1.1.4
1.2.0
1.2.1
1.2.3
1.2.4
1.2.5
1.2.6
1.2.7
1.3.0
1.3.1
1.3.2
1.3.3
1.3.4
1.3.5
1.3.6
1.3.7
1.3.8
1.3.9
1.3.10
1.4.0
1.4.1
1.4.2
1.4.3
1.4.4
1.4.6
1.4.7
1.4.8
1.4.9
1.4.10
1.4.11
1.4.12
1.4.13
1.4.14
1.5.0
1.5.1
1.6.0
1.6.1
1.6.2
1.7.0
1.7.1
1.7.2
1.7.3
1.7.4
1.7.5
1.7.6
1.7.7
1.8.0
1.8.1
1.8.2
1.8.3
1.8.4
1.8.5
1.8.6
1.8.7
1.8.8
1.8.9
1.8.10
1.8.12
1.8.14
1.8.15
1.9.0
1.9.1
1.9.2
1.9.3
1.9.4
1.9.5
1.9.6
1.9.7
1.10.0
1.10.1
1.10.2
1.10.3
1.10.4
1.10.5
1.10.6
1.10.7
1.10.9
1.10.10
1.10.11
1.10.12
1.10.13
1.10.14
1.11.0
1.11.1
1.11.2
1.11.3
1.11.4

Database specific

{
    "last_known_affected_version_range": "<= 1.11.4"
}