GHSA-h892-x453-86wc

Suggest an improvement
Source
https://github.com/advisories/GHSA-h892-x453-86wc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-h892-x453-86wc/GHSA-h892-x453-86wc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-h892-x453-86wc
Aliases
Published
2022-05-13T01:19:33Z
Modified
2024-02-16T08:06:32.612507Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Pippo RCE Vulnerability
Details

Pippo through 1.11.0 allows remote code execution via a command to java.lang.ProcessBuilder because the XstreamEngine component does not use XStream's available protection mechanisms to restrict unmarshalling.

References

Affected packages

Maven / ro.pippo:pippo-core

Package

Name
ro.pippo:pippo-core
View open source insights on deps.dev
Purl
pkg:maven/ro.pippo/pippo-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.0

Affected versions

0.*

0.4.0
0.4.1
0.4.2
0.5.0
0.6.0
0.6.1
0.7.0
0.8.0
0.9.0
0.9.1
0.10.0

1.*

1.0.0
1.1.0
1.2.0
1.3.0
1.4.0
1.5.0
1.6.0
1.7.0
1.8.0
1.9.0
1.10.0
1.11.0

Database specific

{
    "last_known_affected_version_range": "<= 1.11.0"
}

Maven / ro.pippo:pippo-session

Package

Name
ro.pippo:pippo-session
View open source insights on deps.dev
Purl
pkg:maven/ro.pippo/pippo-session

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.0

Affected versions

0.*

0.4.0
0.4.1
0.4.2
0.5.0
0.6.0
0.6.1
0.7.0
0.8.0
0.9.0
0.9.1
0.10.0

1.*

1.0.0
1.1.0
1.2.0
1.3.0
1.4.0
1.5.0
1.6.0
1.7.0
1.8.0
1.9.0
1.10.0
1.11.0

Database specific

{
    "last_known_affected_version_range": "<= 1.11.0"
}