GHSA-h8q5-g2cj-qr5h

Suggest an improvement
Source
https://github.com/advisories/GHSA-h8q5-g2cj-qr5h
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/10/GHSA-h8q5-g2cj-qr5h/GHSA-h8q5-g2cj-qr5h.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-h8q5-g2cj-qr5h
Aliases
Published
2018-10-17T15:43:25Z
Modified
2024-02-16T08:07:07.926981Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack
Details

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

References

Affected packages

Maven / org.apache.tika:tika-core

Package

Name
org.apache.tika:tika-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.tika/tika-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0.1
Fixed
1.19.1

Affected versions

0.*

0.4
0.5
0.6
0.7
0.8
0.9
0.10

1.*

1.0
1.1
1.2
1.3
1.4
1.5
1.6
1.7
1.8
1.9
1.10
1.11
1.12
1.13
1.14
1.15
1.16
1.17
1.18
1.19