GHSA-hcw3-6459-pwhc

Suggest an improvement
Source
https://github.com/advisories/GHSA-hcw3-6459-pwhc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/10/GHSA-hcw3-6459-pwhc/GHSA-hcw3-6459-pwhc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hcw3-6459-pwhc
Aliases
  • CVE-2022-43431
Published
2022-10-19T19:00:22Z
Modified
2024-02-16T08:16:45.398656Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins Compuware Strobe Measurement Plugin Missing Authorization vulnerability
Details

Jenkins Compuware Strobe Measurement Plugin 1.0.1 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.

References

Affected packages

Maven / com.compuware.jenkins:compuware-strobe-measurement

Package

Name
com.compuware.jenkins:compuware-strobe-measurement
View open source insights on deps.dev
Purl
pkg:maven/com.compuware.jenkins/compuware-strobe-measurement

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.2

Affected versions

1.*

1.0.0
1.0.1

Database specific

{
    "last_known_affected_version_range": "<= 1.0.1"
}