GHSA-hj8g-cw8x-2c6m

Suggest an improvement
Source
https://github.com/advisories/GHSA-hj8g-cw8x-2c6m
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/02/GHSA-hj8g-cw8x-2c6m/GHSA-hj8g-cw8x-2c6m.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hj8g-cw8x-2c6m
Aliases
Published
2022-02-24T00:00:53Z
Modified
2023-11-08T04:07:38.874715Z
Severity
  • 7.6 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:H CVSS Calculator
Summary
Cross-site Scripting in Microweber
Details

Microweber prior to version 1.3 is vulnerable to reflected cross-site scripting.

References

Affected packages

Packagist / microweber/microweber

Package

Name
microweber/microweber
Purl
pkg:composer/microweber/microweber

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3

Affected versions

0.*

0.9.346
0.93
0.931
0.934
0.951

1.*

1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.1

v1.*

v1.2.3
v1.2.4
v1.2.5
v1.2.6
v1.2.7
v1.2.8
v1.2.9
v1.2.10
v1.2.11
v1.2.12
v1.2.13
v1.2.14
v1.2.15
v1.2.16
v1.2.17
v1.2.18
v1.2.19
v1.2.20
v1.2.21