GHSA-hjx6-f647-mvf9

Suggest an improvement
Source
https://github.com/advisories/GHSA-hjx6-f647-mvf9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-hjx6-f647-mvf9/GHSA-hjx6-f647-mvf9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hjx6-f647-mvf9
Published
2024-06-12T19:43:04Z
Modified
2024-06-12T20:00:30.033187Z
Severity
  • 6.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L CVSS Calculator
Summary
Invenio-Communities has a Cross-Site Scripting (XSS) vulnerability in React components
Details

Impact

We have identified a Cross-Site Scripting (XSS) vulnerability within certain React components related to community members in the Invenio-Communities module. This vulnerability enables a user to inject a script tag into the Affiliations field during the account registration process. The malicious script is executed when the user creates a new community and is listed as a public member.

The script is triggered whenever any user visits the Members section of any community that includes the compromised user. This can potentially allow the attacker to access personal information, such as cookies, of the visiting user.

Patches

The problem has been patched in v7.8.0. Patches also have been backported in versions v4.2.2 and v2.8.11.

Credits

Thanks to Twitter.com/AliGoodLuck11 for reporting the vulnerability with a detailed description on how to reproduce it!

For more information

If you have any questions or comments about this advisory:

Email us at info@inveniosoftware.org

References

Affected packages

PyPI / invenio-communities

Package

Name
invenio-communities
View open source insights on deps.dev
Purl
pkg:pypi/invenio-communities

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.0.0
Fixed
7.8.0

Affected versions

5.*

5.0.0
5.0.1
5.1.0
5.2.0
5.3.0
5.4.0
5.5.0

6.*

6.0.0
6.1.0
6.1.1
6.2.0
6.2.1
6.3.0
6.4.0
6.5.0
6.6.0
6.6.1
6.7.0

7.*

7.0.0
7.0.1
7.1.0
7.1.1
7.1.2
7.2.0
7.2.1
7.2.2
7.2.3
7.3.0
7.4.0
7.5.0
7.6.0
7.7.0
7.7.1
7.7.2
7.7.3
7.7.4

PyPI / invenio-communities

Package

Name
invenio-communities
View open source insights on deps.dev
Purl
pkg:pypi/invenio-communities

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.0.0
Fixed
4.2.2

Affected versions

3.*

3.0.0
3.0.1
3.0.2
3.1.0
3.2.0
3.2.1
3.2.2
3.2.3
3.2.4
3.2.5
3.2.6

4.*

4.0.0
4.0.1
4.0.2
4.0.3
4.0.4
4.0.5
4.0.6
4.0.7
4.1.0
4.1.1
4.1.2
4.2.0
4.2.1

PyPI / invenio-communities

Package

Name
invenio-communities
View open source insights on deps.dev
Purl
pkg:pypi/invenio-communities

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.8.11

Affected versions

1.*

1.0.0a1
1.0.0a2
1.0.0a3
1.0.0a4
1.0.0a5
1.0.0a6
1.0.0a7
1.0.0a8
1.0.0a9
1.0.0a10
1.0.0a11
1.0.0a12
1.0.0a13
1.0.0a14
1.0.0a15
1.0.0a16
1.0.0a17
1.0.0a18
1.0.0a19
1.0.0a20
1.0.0a21
1.0.0a22
1.0.0a23
1.0.0a24
1.0.0a25
1.0.0a26
1.0.0a27
1.0.0a28
1.0.0a29

2.*

2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.1.0
2.1.1
2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.3.0.dev0
2.3.0.dev1
2.3.0
2.3.1
2.3.2
2.4.0.dev0
2.4.0.dev1
2.5.0.dev0
2.5.0.dev1
2.5.0.dev2
2.6.0.dev0
2.6.0.dev1
2.6.0.dev2
2.6.0.dev3
2.6.0.dev4
2.6.0.dev5
2.6.0.dev6
2.6.0.dev7
2.6.0.dev8
2.7.0.dev0
2.7.0.dev1
2.7.0.dev2
2.7.0.dev3
2.7.0.dev4
2.7.0.dev5
2.7.0.dev6
2.7.0.dev7
2.7.0.dev8
2.7.0.dev9
2.8.0.dev0
2.8.0.dev1
2.8.0.dev2
2.8.0.dev3
2.8.0.dev4
2.8.0.dev5
2.8.0.dev6
2.8.0.dev7
2.8.0.dev8
2.8.0.dev9
2.8.0.dev10
2.8.0.dev11
2.8.0.dev12
2.8.0.dev13
2.8.0.dev14
2.8.0.dev15
2.8.0.dev16
2.8.0.dev17
2.8.0.dev18
2.8.0.dev19
2.8.0.dev20
2.8.0.dev21
2.8.0.dev22
2.8.0.dev23
2.8.0.dev24
2.8.0.dev25
2.8.0.dev26
2.8.0.dev27
2.8.0.dev28
2.8.0.dev29
2.8.0.dev30
2.8.0.dev31
2.8.0
2.8.1
2.8.2
2.8.3
2.8.4
2.8.5
2.8.6
2.8.7
2.8.8
2.8.9