GHSA-hp8h-7x69-4wmv

Suggest an improvement
Source
https://github.com/advisories/GHSA-hp8h-7x69-4wmv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/04/GHSA-hp8h-7x69-4wmv/GHSA-hp8h-7x69-4wmv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hp8h-7x69-4wmv
Aliases
Published
2024-04-10T17:16:15Z
Modified
2024-04-11T14:31:30Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
zcap has incomplete expiration checks in capability chains.
Details

Impact

When invoking a capability with a chain depth of 2, i.e., it is delegated directly from the root capability, the expires property is not properly checked against the current date or other date param. This can allow invocations outside of the original intended time period. A zcap still cannot be invoked without being able to use the associated private key material.

Patches

@digitalbazaar/zcap v9.0.1 fixes expiration checking.

Workarounds

A zcap could be revoked at any time.

References

https://github.com/digitalbazaar/zcap/pull/82

References

Affected packages

npm / @digitalbazaar/zcap

Package

Name
@digitalbazaar/zcap
View open source insights on deps.dev
Purl
pkg:npm/%40digitalbazaar/zcap

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.0.1