GHSA-hpqj-7cj6-hfj8

Suggest an improvement
Source
https://github.com/advisories/GHSA-hpqj-7cj6-hfj8
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/10/GHSA-hpqj-7cj6-hfj8/GHSA-hpqj-7cj6-hfj8.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hpqj-7cj6-hfj8
Aliases
Published
2022-10-04T00:00:22Z
Modified
2023-11-08T04:10:25.121666Z
Severity
  • 7.8 (High) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Snyk CLI affected by Command Injection vulnerability
Details

Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. Exploitation could follow from the common practice of viewing untrusted files in the Visual Studio Code editor, for example. The original demonstration was with shell metacharacters in the vendor.json ignore field, affecting snyk-go-plugin before 1.19.1. This affects, for example, the Snyk TeamCity plugin (which does not update automatically) before 20220930.142957.

References

Affected packages

npm / snyk

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.996.0

npm / snyk-go-plugin

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.19.1