GHSA-hqqv-9x3v-mp7w

Suggest an improvement
Source
https://github.com/advisories/GHSA-hqqv-9x3v-mp7w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/03/GHSA-hqqv-9x3v-mp7w/GHSA-hqqv-9x3v-mp7w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hqqv-9x3v-mp7w
Aliases
Published
2021-03-18T19:27:20Z
Modified
2024-02-17T05:33:13.533268Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Privilege Escalation Flaw in Elasticsearch
Details

The fix for CVE-2020-7009 was found to be incomplete. Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys and also authentication tokens. An attacker who is able to generate an API key and an authentication token can perform a series of steps that result in an authentication token being generated with elevated privileges.

References

Affected packages

Maven / org.elasticsearch:elasticsearch

Package

Name
org.elasticsearch:elasticsearch
View open source insights on deps.dev
Purl
pkg:maven/org.elasticsearch/elasticsearch

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.7.0
Fixed
6.8.8

Affected versions

6.*

6.7.0
6.7.1
6.7.2
6.8.0
6.8.1
6.8.2
6.8.3
6.8.4
6.8.5
6.8.6
6.8.7

Maven / org.elasticsearch:elasticsearch

Package

Name
org.elasticsearch:elasticsearch
View open source insights on deps.dev
Purl
pkg:maven/org.elasticsearch/elasticsearch

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0
Fixed
7.6.2

Affected versions

7.*

7.0.0
7.0.1
7.1.0
7.1.1
7.2.0
7.2.1
7.3.0
7.3.1
7.3.2
7.4.0
7.4.1
7.4.2
7.5.0
7.5.1
7.5.2
7.6.0
7.6.1