GHSA-hrf3-622q-8366

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-hrf3-622q-8366/GHSA-hrf3-622q-8366.json
Aliases
  • CVE-2022-31605
Published
2022-06-22T21:22:46Z
Modified
2022-06-22T21:31:57.507444Z
Details

Impact

NVFLARE contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of Untrusted Data, may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.

All versions before 2.1.2 are affected. CVSS Score = 9.8 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Patches

The patch will be included in nvflare==2.1.2

Workarounds

Change yaml.load() to yaml.safe_load()

Additional information

Issue Found by: Oliver Sellwood (@Nintorac)

References

Affected packages

PyPI / nvflare

nvflare

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
2.1.2

Affected versions

0.*

0.1.3
0.9.0

1.*

1.0.0
1.0.1
1.0.2
1.1.0
1.1.1

2.*

2.0.0
2.0.1
2.0.10
2.0.11
2.0.12
2.0.13
2.0.14
2.0.15
2.0.16
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.1.0
2.1.1