GHSA-hw83-jpxr-g225

Suggest an improvement
Source
https://github.com/advisories/GHSA-hw83-jpxr-g225
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-hw83-jpxr-g225/GHSA-hw83-jpxr-g225.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-hw83-jpxr-g225
Aliases
Published
2022-05-13T01:31:34Z
Modified
2024-02-16T08:17:12.406066Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Jenkins Monitoring Plugin vulnerable to Denial of service vulnerability
Details

A denial of service vulnerability exists in Jenkins Monitoring Plugin 1.74.0 and earlier in PluginImpl.java that allows attackers to kill threads running on the Jenkins master.

References

Affected packages

Maven / org.jvnet.hudson.plugins:monitoring

Package

Name
org.jvnet.hudson.plugins:monitoring
View open source insights on deps.dev
Purl
pkg:maven/org.jvnet.hudson.plugins/monitoring

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.75.0

Affected versions

1.*

1.8.1
1.8.2
1.9.0
1.10.0
1.12.0
1.13.0
1.14.0
1.15.0
1.15.1
1.17.0
1.18.0
1.19.0
1.20.0
1.21.0
1.22.0
1.23.0
1.25.0
1.26.0
1.27.0
1.28.0
1.29.0
1.30.0
1.31.0
1.32.0
1.32.1
1.33.0
1.34.0
1.35.0
1.36.0
1.37.0
1.38.0
1.39.0
1.40.0
1.41.0
1.42.0
1.43.0
1.44.0
1.45.0
1.46.0
1.47.0
1.48.0
1.49.0
1.50.0
1.51.0
1.52.0
1.52.1
1.53.0
1.53.1
1.54.0
1.55.0
1.56.0
1.57.0
1.58.0
1.59.0
1.60.0
1.61.0
1.62.0
1.63.0
1.64.0
1.65.0
1.65.1
1.66.0
1.67.0
1.68.0
1.68.1
1.69.0
1.69.1
1.70.0
1.71.0
1.72.0
1.73.0
1.73.1
1.74.0

Database specific

{
    "last_known_affected_version_range": "<= 1.74.0"
}