GHSA-j2fp-9wp5-mg66

Suggest an improvement
Source
https://github.com/advisories/GHSA-j2fp-9wp5-mg66
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-j2fp-9wp5-mg66/GHSA-j2fp-9wp5-mg66.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-j2fp-9wp5-mg66
Aliases
  • CVE-2017-1000442
Published
2022-05-14T03:50:13Z
Modified
2024-05-19T02:24:41.129462Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar
Details

Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace

References

Affected packages

Packagist / passbolt/passbolt_api

Package

Name
passbolt/passbolt_api
Purl
pkg:composer/passbolt/passbolt_api

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.5

Affected versions

v1.*

v1.0.5
v1.0.6
v1.0.7
v1.0.8
v1.0.9
v1.0.10
v1.0.11
v1.0.12
v1.0.13
v1.0.14
v1.1.0
v1.2.0
v1.2.1
v1.3.0
v1.3.1
v1.3.2
v1.4.0
v1.5.1
v1.6.0
v1.6.1
v1.6.2
v1.6.3
v1.6.4