GHSA-j2mj-g8jp-gjfm

Suggest an improvement
Source
https://github.com/advisories/GHSA-j2mj-g8jp-gjfm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/09/GHSA-j2mj-g8jp-gjfm/GHSA-j2mj-g8jp-gjfm.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-j2mj-g8jp-gjfm
Aliases
  • CVE-2022-41228
Published
2022-09-22T00:00:28Z
Modified
2023-11-08T04:10:27.584751Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N CVSS Calculator
Summary
Jenkins NS-ND Integration Performance Publisher Plugin vulnerable to Missing Authorization
Details

A missing permission check in Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.129 and earlier allows attackers with Overall/Read permissions to connect to an attacker-specified webserver using attacker-specified credentials. Version 4.8.0.130 requires POST requests and Overall/Administer permission for the affected form validation method.

References

Affected packages

Maven / io.jenkins.plugins:cavisson-ns-nd-integration

Package

Name
io.jenkins.plugins:cavisson-ns-nd-integration
View open source insights on deps.dev
Purl
pkg:maven/io.jenkins.plugins/cavisson-ns-nd-integration

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.8.0.130

Affected versions

4.*

4.6.0.23
4.6.0.24
4.6.1.40
4.6.1.65
4.6.1.65.1
4.6.1.65.2
4.6.1.66
4.6.1.68
4.6.1.69
4.6.1.70
4.6.1.76
4.6.1.78
4.6.1.79
4.6.1.80
4.6.1.82
4.6.1.83
4.6.1.85
4.6.1.93
4.8.0.77
4.8.0.129

Database specific

{
    "last_known_affected_version_range": "<= 4.8.0.129"
}