GHSA-j49g-mp79-5vm5

Suggest an improvement
Source
https://github.com/advisories/GHSA-j49g-mp79-5vm5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/08/GHSA-j49g-mp79-5vm5/GHSA-j49g-mp79-5vm5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-j49g-mp79-5vm5
Aliases
  • CVE-2017-16203
Published
2018-08-06T20:06:29Z
Modified
2023-11-08T03:59:11.080223Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
coffe-script is malware
Details

The coffe-script package is a piece of malware that steals sensitive data such as a user's private SSH key and bash history, sending them to attacker controlled locations.

All versions have been unpublished from the npm registry.

Recommendation

If you have found coffe-script installed in your environment, you should: 1. Delete the package 2. Clear your npm cache 3. Ensure it is not present in any other package.json files on your system 4. Regenerate your SSH keys, registry credentials, tokens, and any other sensitive credentials that may have been present in your bash history.

Additionally, any service which may have been exposed via credentials in your bash history or accessible via your ssh keys, such as a database, should be reviewed for indicators of compromise as well.

References

Affected packages

npm / coffe-script

Package

Affected ranges

Affected versions

1.*

1.0.1