GHSA-j77q-2qqg-6989

Suggest an improvement
Source
https://github.com/advisories/GHSA-j77q-2qqg-6989
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/10/GHSA-j77q-2qqg-6989/GHSA-j77q-2qqg-6989.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-j77q-2qqg-6989
Aliases
Published
2018-10-18T19:24:26Z
Modified
2024-03-08T05:17:48.390493Z
Severity
  • 10.0 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H CVSS Calculator
Summary
Apache Struts vulnerable to remote arbitrary command execution due to improper input validation
Details

Apache Struts versions prior to 2.3.32 and 2.5.10.1 contain incorrect exception handling and error-message generation during file-upload attempts using the Jakarta Multipart parser, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

References

Affected packages

Maven / org.apache.struts:struts2-core

Package

Name
org.apache.struts:struts2-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.struts/struts2-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.3.0
Fixed
2.3.32

Affected versions

2.*

2.3.1
2.3.1.1
2.3.1.2
2.3.3
2.3.4
2.3.4.1
2.3.7
2.3.8
2.3.12
2.3.14
2.3.14.1
2.3.14.2
2.3.14.3
2.3.15
2.3.15.1
2.3.15.2
2.3.15.3
2.3.16
2.3.16.1
2.3.16.2
2.3.16.3
2.3.20
2.3.20.1
2.3.20.3
2.3.24
2.3.24.1
2.3.24.3
2.3.28
2.3.28.1
2.3.29
2.3.30
2.3.31

Database specific

{
    "last_known_affected_version_range": "<= 2.3.31"
}

Maven / org.apache.struts:struts2-core

Package

Name
org.apache.struts:struts2-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.struts/struts2-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.5.0
Fixed
2.5.10.1

Affected versions

2.*

2.5
2.5.1
2.5.2
2.5.5
2.5.8
2.5.10

Database specific

{
    "last_known_affected_version_range": "<= 2.5.10"
}