GHSA-j8mg-pqc5-x9gj

Suggest an improvement
Source
https://github.com/advisories/GHSA-j8mg-pqc5-x9gj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-j8mg-pqc5-x9gj/GHSA-j8mg-pqc5-x9gj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-j8mg-pqc5-x9gj
Aliases
Published
2024-06-04T12:31:05Z
Modified
2024-06-25T02:44:08.133422Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
MLFlow unsafe deserialization
Details

Deserialization of untrusted data can occur in versions of the MLflow platform running version 2.0.0rc0 or newer, enabling a maliciously uploaded Tensorflow model to run arbitrary code on an end user’s system when interacted with.

References

Affected packages

PyPI / mlflow

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0rc0
Last affected
2.14.1

Affected versions

2.*

2.0.0rc0
2.0.0
2.0.1
2.1.0
2.1.1
2.2.0
2.2.1
2.2.2
2.3.0
2.3.1
2.3.2
2.4.0
2.4.1
2.4.2
2.5.0
2.6.0
2.7.0
2.7.1
2.8.0
2.8.1
2.9.0
2.9.1
2.9.2
2.10.0
2.10.1
2.10.2
2.11.0
2.11.1
2.11.2
2.11.3
2.11.4
2.12.0
2.12.1
2.12.2
2.13.0
2.13.1
2.13.2
2.14.0rc0
2.14.0
2.14.1