GHSA-j8mx-x32r-5rf4

Suggest an improvement
Source
https://github.com/advisories/GHSA-j8mx-x32r-5rf4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-j8mx-x32r-5rf4/GHSA-j8mx-x32r-5rf4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-j8mx-x32r-5rf4
Aliases
Published
2022-05-17T02:36:37Z
Modified
2024-02-16T08:07:07.796408Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
phpMyAdmin XSS Vulnerability
Details

An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10. This issue is resolved by using a copy of a hash to avoid a race condition. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.

References

Affected packages

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.6
Fixed
4.6.5

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.4
Fixed
4.4.15.9

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.0
Fixed
4.0.10.18

Affected versions

4.*

4.0.0
4.0.1
4.0.2
4.0.3
4.0.4
4.0.4.1
4.0.4.2
4.0.5
4.0.6
4.0.7
4.0.8
4.0.9
4.0.10
4.0.10.1
4.0.10.2
4.0.10.3
4.0.10.4
4.0.10.5
4.0.10.6
4.0.10.7
4.0.10.8
4.0.10.9