GHSA-jgj9-6v78-6g8m

Suggest an improvement
Source
https://github.com/advisories/GHSA-jgj9-6v78-6g8m
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-jgj9-6v78-6g8m/GHSA-jgj9-6v78-6g8m.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-jgj9-6v78-6g8m
Aliases
Published
2022-05-13T01:46:13Z
Modified
2023-11-08T03:59:22.122736Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Improper Authentication In Apache NiFi
Details

In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, if an anonymous user request is replicated to another node, the originating node identity is used rather than the "anonymous" user.

References

Affected packages

Maven / org.apache.nifi:nifi

Package

Name
org.apache.nifi:nifi
View open source insights on deps.dev
Purl
pkg:maven/org.apache.nifi/nifi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.2

Affected versions

0.*

0.0.1-incubating
0.0.2-incubating
0.1.0-incubating
0.2.0-incubating
0.2.1
0.3.0
0.4.0
0.4.1
0.5.0
0.5.1
0.6.0
0.6.1
0.7.0
0.7.1

Maven / org.apache.nifi:nifi

Package

Name
org.apache.nifi:nifi
View open source insights on deps.dev
Purl
pkg:maven/org.apache.nifi/nifi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0.0
Fixed
1.1.2

Affected versions

1.*

1.0.0
1.0.1
1.1.0
1.1.1