GHSA-jjvp-wfp8-rv69

Suggest an improvement
Source
https://github.com/advisories/GHSA-jjvp-wfp8-rv69
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-jjvp-wfp8-rv69/GHSA-jjvp-wfp8-rv69.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-jjvp-wfp8-rv69
Aliases
Published
2023-01-06T21:30:40Z
Modified
2023-11-08T04:00:15.958655Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
globalpom-utils has Insecure Temporary File
Details

A vulnerability has been found in devent globalpom-utils up to 4.5.0 and classified as critical. This vulnerability affects the function createTmpDir of the file globalpomutils-fileresources/src/main/java/com/anrisoftware/globalpom/fileresourcemanager/FileResourceManagerProvider.java. The manipulation leads to insecure temporary file. The attack can be initiated remotely. Upgrading to version 4.5.1 can address this issue. The name of the patch is 77a820bac2f68e662ce261ecb050c643bd7ee560. It is recommended to upgrade the affected component. VDB-217570 is the identifier assigned to this vulnerability.

References

Affected packages

Maven / com.anrisoftware.globalpom:globalpomutils

Package

Name
com.anrisoftware.globalpom:globalpomutils
View open source insights on deps.dev
Purl
pkg:maven/com.anrisoftware.globalpom/globalpomutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.5.1