GHSA-jp8r-jh5j-cgwf

Suggest an improvement
Source
https://github.com/advisories/GHSA-jp8r-jh5j-cgwf
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-jp8r-jh5j-cgwf/GHSA-jp8r-jh5j-cgwf.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-jp8r-jh5j-cgwf
Aliases
  • CVE-2019-10423
Published
2022-05-24T16:56:46Z
Modified
2024-02-17T05:35:27.347120Z
Severity
  • 3.3 (Low) CVSS_V3 - CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Jenkins CodeScan Plugin has Insufficiently Protected Credentials
Details

CodeScan Plugin stores an API key unencrypted in its global configuration file com.villagechief.codescan.jenkins.CodeScanBuilder.xml on the Jenkins controller. This API key can be viewed by users with access to the Jenkins controller file system.

As of publication of this advisory, there is no fix.

References

Affected packages

Maven / com.villagechief.codescan.jenkins:codescan

Package

Name
com.villagechief.codescan.jenkins:codescan
View open source insights on deps.dev
Purl
pkg:maven/com.villagechief.codescan.jenkins/codescan

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.0

Affected versions

1.*

1.0