GHSA-jphj-5g3m-w7x6

Suggest an improvement
Source
https://github.com/advisories/GHSA-jphj-5g3m-w7x6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-jphj-5g3m-w7x6/GHSA-jphj-5g3m-w7x6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-jphj-5g3m-w7x6
Aliases
Published
2022-05-14T00:57:52Z
Modified
2023-11-08T03:59:46.638175Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Ignite Realtime Openfire vulnerable to cross-site scripting
Details

Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

References

Affected packages

Maven / org.igniterealtime.openfire:parent

Package

Name
org.igniterealtime.openfire:parent
View open source insights on deps.dev
Purl
pkg:maven/org.igniterealtime.openfire/parent

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.9.2