GHSA-jvxx-v45p-v5vf

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-jvxx-v45p-v5vf/GHSA-jvxx-v45p-v5vf.json
Published
2022-06-23T06:45:03Z
Modified
2022-06-23T06:45:03Z
Details

Impact

Passing some special values to the filter and filterout parameters can cause an abnormally high CPU. Impact on the performance of the servers and RSSHub services.

Patches

It is fixed in 5c4177441417b44a6e45c3c63e9eac2504abeb5b , please update to this or the later versions as soon as possible.

Credits

@Rongronggg9

References

A full report will be disclosed after 120 hours.

For more information

If you have any questions or comments about this advisory: * Open an issue in https://github.com/DIYgod/RSSHub/issues * Email us at i@diygod.me

References

Affected packages

npm / rsshub

rsshub

Affected ranges

Type
SEMVER
Events
Introduced
0

Affected versions

Database specific

{
    "last_known_affected_version_range": "<= 1.0.0"
}