GHSA-jww4-2793-9gmg

Suggest an improvement
Source
https://github.com/advisories/GHSA-jww4-2793-9gmg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-jww4-2793-9gmg/GHSA-jww4-2793-9gmg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-jww4-2793-9gmg
Aliases
Published
2022-05-24T16:58:48Z
Modified
2024-02-18T05:32:25.009806Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Jenkins CRX Content Package Deployer Plugin subject to Missing Authorization
Details

A missing permission check in Jenkins CRX Content Package Deployer Plugin prior to version 1.9 allowed attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. This issue is patched in 1.9

References

Affected packages

Maven / org.jenkins-ci.plugins:crx-content-package-deployer

Package

Name
org.jenkins-ci.plugins:crx-content-package-deployer
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/crx-content-package-deployer

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9

Affected versions

1.*

1.0
1.1
1.2
1.2.1
1.2.2
1.3
1.3.1
1.3.2
1.4
1.5
1.5.1
1.5.2
1.5.3
1.5.4
1.6
1.6.1
1.6.2
1.6.3
1.7
1.7.1
1.7.2
1.8
1.8.1