GHSA-jxr6-7qg5-8wv6

Suggest an improvement
Source
https://github.com/advisories/GHSA-jxr6-7qg5-8wv6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-jxr6-7qg5-8wv6/GHSA-jxr6-7qg5-8wv6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-jxr6-7qg5-8wv6
Aliases
Published
2023-03-22T21:30:17Z
Modified
2023-11-08T04:11:12.876132Z
Severity
  • 6.7 (Medium) CVSS_V3 - CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N CVSS Calculator
Summary
OpenNMS Meridian and Horizon vulnerable to Cross-Site Request Forgery
Details

A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

References

Affected packages

Maven / org.opennms:opennms-webapp

Package

Name
org.opennms:opennms-webapp
View open source insights on deps.dev
Purl
pkg:maven/org.opennms/opennms-webapp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
31.0.6