GHSA-m3f4-957x-m785

Suggest an improvement
Source
https://github.com/advisories/GHSA-m3f4-957x-m785
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/02/GHSA-m3f4-957x-m785/GHSA-m3f4-957x-m785.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-m3f4-957x-m785
Aliases
Published
2024-02-12T21:30:55Z
Modified
2024-03-01T14:41:48Z
Severity
  • 3.5 (Low) CVSS_V3 - CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L CVSS Calculator
Summary
lambda-middleware Inefficient Regular Expression Complexity vulnerability
Details

A vulnerability, which was classified as problematic, has been found in dbartholomae lambda-middleware frameguard up to 1.0.4. Affected by this issue is some unknown functionality of the file packages/json-deserializer/src/JsonDeserializer.ts of the component JSON Mime-Type Handler. The manipulation leads to inefficient regular expression complexity. Upgrading to version 1.1.0 is able to address this issue. The patch is identified as f689404d830cbc1edd6a1018d3334ff5f44dc6a6. It is recommended to upgrade the affected component. VDB-253406 is the identifier assigned to this vulnerability.

References

Affected packages

npm / @lambda-middleware/json-deserializer

Package

Name
@lambda-middleware/json-deserializer
View open source insights on deps.dev
Purl
pkg:npm/%40lambda-middleware/json-deserializer

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.0