GHSA-m728-qvxh-xfjq

Suggest an improvement
Source
https://github.com/advisories/GHSA-m728-qvxh-xfjq
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-m728-qvxh-xfjq/GHSA-m728-qvxh-xfjq.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-m728-qvxh-xfjq
Aliases
  • CVE-2017-8446
Published
2022-05-13T01:36:10Z
Modified
2023-11-08T03:59:28.105958Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Improper Privilege Management in X-Pack
Details

The Reporting feature in X-Pack in versions prior to 5.5.2 and standalone Reporting plugin versions versions prior to 2.4.6 had an impersonation vulnerability. A user with the reporting_user role could execute a report with the permissions of another reporting user, possibly gaining access to sensitive data.

References

Affected packages

Maven / org.elasticsearch.plugin:x-pack

Package

Name
org.elasticsearch.plugin:x-pack
View open source insights on deps.dev
Purl
pkg:maven/org.elasticsearch.plugin/x-pack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.5.2