GHSA-mc22-25r3-2w9w

Suggest an improvement
Source
https://github.com/advisories/GHSA-mc22-25r3-2w9w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-mc22-25r3-2w9w/GHSA-mc22-25r3-2w9w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mc22-25r3-2w9w
Aliases
Published
2022-05-13T01:40:56Z
Modified
2024-02-18T05:32:33.399093Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Parameterized Trigger Plugin fails to check Item/Build permission
Details

Parameterized Trigger Plugin fails to check Item/Build permission: The Parameterized Trigger Plugin did not check the build authentication it was running as and allowed triggering any other project in Jenkins. The plugin has been adapted to now check for Item/Build permission before triggering a downstream build.

References

Affected packages

Maven / org.jenkins-ci.plugins:parameterized-trigger

Package

Name
org.jenkins-ci.plugins:parameterized-trigger
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/parameterized-trigger

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.35.1

Affected versions

2.*

2.5
2.6
2.7
2.8
2.9
2.10
2.11
2.12
2.13
2.14
2.15
2.16
2.17
2.18
2.19
2.20
2.21
2.22
2.23
2.24
2.25
2.26
2.27
2.28
2.29
2.30
2.31
2.32
2.33
2.34
2.35