GHSA-mcvg-g9wx-v5vx

Suggest an improvement
Source
https://github.com/advisories/GHSA-mcvg-g9wx-v5vx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/09/GHSA-mcvg-g9wx-v5vx/GHSA-mcvg-g9wx-v5vx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mcvg-g9wx-v5vx
Aliases
Published
2022-09-20T00:00:20Z
Modified
2023-11-08T04:10:12.172660Z
Severity
  • 9.6 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H CVSS Calculator
Summary
Valine code injection vulnerability
Details

Valine was discovered to contain a remote code execution (RCE) vulnerability which allows attackers to execute arbitrary code via a crafted POST request.

References

Affected packages

npm / valine

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.0