GHSA-mf7c-35mq-75pj

Suggest an improvement
Source
https://github.com/advisories/GHSA-mf7c-35mq-75pj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-mf7c-35mq-75pj/GHSA-mf7c-35mq-75pj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mf7c-35mq-75pj
Aliases
Published
2022-05-14T03:24:59Z
Modified
2023-11-08T03:58:33.830753Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Insecure Inherited Permissions in Apache Hadoop
Details

In Apache Hadoop 2.x before 2.7.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

References

Affected packages

Maven / org.apache.hadoop:hadoop-common

Package

Name
org.apache.hadoop:hadoop-common
View open source insights on deps.dev
Purl
pkg:maven/org.apache.hadoop/hadoop-common

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.0.0-alpha
Fixed
2.7.4

Affected versions

2.*

2.0.0-alpha
2.0.1-alpha
2.0.2-alpha
2.0.3-alpha
2.0.4-alpha
2.0.5-alpha
2.0.6-alpha
2.1.0-beta
2.1.1-beta
2.2.0
2.3.0
2.4.0
2.4.1
2.5.0
2.5.1
2.5.2
2.6.0
2.6.1
2.6.2
2.6.3
2.6.4
2.6.5
2.7.0
2.7.1
2.7.2
2.7.3

Database specific

{
    "last_known_affected_version_range": "<= 2.7.3"
}