GHSA-mfg4-9xf4-f45q

Suggest an improvement
Source
https://github.com/advisories/GHSA-mfg4-9xf4-f45q
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-mfg4-9xf4-f45q/GHSA-mfg4-9xf4-f45q.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mfg4-9xf4-f45q
Aliases
  • CVE-2013-4202
Published
2022-05-14T01:58:45Z
Modified
2024-05-19T02:24:38.322703Z
Summary
OpenStack Cinder Denial of Service using XML entities
Details

The (1) backup (api/contrib/backups.py) and (2) volume transfer (contrib/volume_transfer.py) APIs in OpenStack Cinder Grizzly 2013.1.3 and earlier allows remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack. NOTE: this issue is due to an incomplete fix for CVE-2013-1664.

References

Affected packages

PyPI / cinder

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.0a0