GHSA-mfwh-gqx8-c787

Suggest an improvement
Source
https://github.com/advisories/GHSA-mfwh-gqx8-c787
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/08/GHSA-mfwh-gqx8-c787/GHSA-mfwh-gqx8-c787.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mfwh-gqx8-c787
Aliases
Published
2019-08-06T01:43:40Z
Modified
2024-02-16T08:21:19.098380Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Allocation of Resources Without Limits or Throttling in Apache Tika
Details

A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Users should upgrade to 1.22 or later.

References

Affected packages

Maven / org.apache.tika:tika-core

Package

Name
org.apache.tika:tika-core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.tika/tika-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.7
Fixed
1.22

Affected versions

1.*

1.7
1.8
1.9
1.10
1.11
1.12
1.13
1.14
1.15
1.16
1.17
1.18
1.19
1.19.1
1.20
1.21