GHSA-mm33-5vfq-3mm3

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/04/GHSA-mm33-5vfq-3mm3/GHSA-mm33-5vfq-3mm3.json
Aliases
Published
2022-04-27T22:28:59Z
Modified
2022-09-21T03:38:48.519113Z
Details

There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577.

Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1

Impact

CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks.

Releases

The FIXED releases are available at the normal locations.

Workarounds

Set a CSP for your API responses manually.

References

Affected packages

RubyGems / actionpack

actionpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
5.2.0
Fixed
5.2.7.1

Affected versions

5.*

5.2.0
5.2.1
5.2.1.1
5.2.1.rc1
5.2.2
5.2.2.1
5.2.2.rc1
5.2.3
5.2.3.rc1
5.2.4
5.2.4.1
5.2.4.2
5.2.4.3
5.2.4.4
5.2.4.5
5.2.4.6
5.2.4.rc1
5.2.5
5.2.6
5.2.6.1
5.2.6.2
5.2.6.3
5.2.7

Database specific

{
    "last_known_affected_version_range": "<= 5.2.7.0"
}

RubyGems / actionpack

actionpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.0.0
Fixed
6.0.4.8

Affected versions

6.*

6.0.0
6.0.1
6.0.1.rc1
6.0.2
6.0.2.1
6.0.2.2
6.0.2.rc1
6.0.2.rc2
6.0.3
6.0.3.1
6.0.3.2
6.0.3.3
6.0.3.4
6.0.3.5
6.0.3.6
6.0.3.7
6.0.3.rc1
6.0.4
6.0.4.1
6.0.4.2
6.0.4.3
6.0.4.4
6.0.4.5
6.0.4.6
6.0.4.7

Database specific

{
    "last_known_affected_version_range": "<= 6.0.4.7"
}

RubyGems / actionpack

actionpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
6.1.0
Fixed
6.1.5.1

Affected versions

6.*

6.1.0
6.1.1
6.1.2
6.1.2.1
6.1.3
6.1.3.1
6.1.3.2
6.1.4
6.1.4.1
6.1.4.2
6.1.4.3
6.1.4.4
6.1.4.5
6.1.4.6
6.1.4.7
6.1.5

Database specific

{
    "last_known_affected_version_range": "<= 6.1.5.0"
}

RubyGems / actionpack

actionpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
7.0.0
Fixed
7.0.2.4

Affected versions

7.*

7.0.0
7.0.1
7.0.2
7.0.2.1
7.0.2.2
7.0.2.3

Database specific

{
    "last_known_affected_version_range": "<= 7.0.2.3"
}