GHSA-mq6c-fh97-4gwv

Suggest an improvement
Source
https://github.com/advisories/GHSA-mq6c-fh97-4gwv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/07/GHSA-mq6c-fh97-4gwv/GHSA-mq6c-fh97-4gwv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mq6c-fh97-4gwv
Aliases
Published
2018-07-18T21:20:34Z
Modified
2023-11-08T04:00:16.567310Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Denial of Service vulnerability with large JSON payloads in fastify
Details

Affected versions of fastify are vulnerable to a denial of service when processing a request with Content-Type set to application/json and a very large payload.

Recommendation

Update to version 0.38.0 or later.

References

Affected packages

npm / fastify

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.38.0

Database specific

{
    "last_known_affected_version_range": "<= 0.37.0"
}