GHSA-mrpv-5pmr-p92h

Suggest an improvement
Source
https://github.com/advisories/GHSA-mrpv-5pmr-p92h
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/02/GHSA-mrpv-5pmr-p92h/GHSA-mrpv-5pmr-p92h.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mrpv-5pmr-p92h
Aliases
Published
2023-02-23T09:30:17Z
Modified
2023-11-08T04:11:52.794751Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Improper Privilege Management in Apache Sling
Details

Privilege Escalation vulnerability in Apache Software Foundation Apache Sling. Any content author is able to create i18n dictionaries in the repository in a location the author has write access to. As these translations are used across the whole product, it allows an author to change any text or dialog in the product. For example an attacker might fool someone by changing the text on a delete button to "Info". This issue affects the i18n module of Apache Sling versions before 2.6.2. Version 2.6.2 and higher limit by default i18m dictionaries to certain paths in the repository (/libs and /apps). Users of the module are advised to update to version 2.6.2 or higher, check the configuration for resource loading and then adjust the access permissions for the configured path accordingly.

References

Affected packages

Maven / org.apache.sling:org.apache.sling.i18n

Package

Name
org.apache.sling:org.apache.sling.i18n
View open source insights on deps.dev
Purl
pkg:maven/org.apache.sling/org.apache.sling.i18n

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.2

Affected versions

2.*

2.0.2
2.0.4
2.1.0
2.1.2
2.2.0
2.2.2
2.2.4
2.2.6
2.2.8
2.2.10
2.3.2
2.4.2
2.4.4
2.4.6
2.4.8
2.4.10
2.5.0
2.5.2
2.5.4
2.5.6
2.5.8
2.5.10
2.5.12
2.5.14
2.5.16
2.5.18