GHSA-mrx3-gxjx-hjqj

Suggest an improvement
Source
https://github.com/advisories/GHSA-mrx3-gxjx-hjqj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/01/GHSA-mrx3-gxjx-hjqj/GHSA-mrx3-gxjx-hjqj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mrx3-gxjx-hjqj
Aliases
Published
2024-01-29T22:30:54Z
Modified
2024-07-08T19:48:17Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS Calculator
  • 7.1 (High) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N CVSS Calculator
Summary
Authentik vulnerable to PKCE downgrade attack
Details

Summary

PKCE is a very important countermeasure in OAuth2 , both for public and confidential clients. It protects against CSRF attacks and code injection attacks. Because of this bug, an attacker can circumvent the protection PKCE offers.

Patches

authentik 2023.8.7 and 2023.10.7 fix this issue.

Details

There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge’ parameter to the authorization request and adds thecodeverifier’ parameter to the token request. We recently fixed a downgrade attack (in v2023.8.5 and 2023.10.4) where if the attacker removed the code_verifier’ parameter in the token request, authentik would allow the request to pass, thus circumventing PKCE’s protection. However, in the latest version of the software, another downgrade scenario is still possible: if the attacker removes thecodechallenge’ parameter from the authorization request, authentik will also not do the PKCE check.

Note that this type of downgrade enables an attacker to perform a code injection attack, even if the OAuth client is using PKCE (which is supposed to protect against code injection attacks). To start the attack, the attacker must initiate the authorization process without that code_challenge’ parameter in the authorization request. But this is easy to do (just use a phishing site or email to trick the user into clicking on a link that the attacker controls – the authorization link without thatcode_challenge’ parameter).

The OAuth BCP (https://datatracker.ietf.org/doc/html/draft-ietf-oauth-security-topics) explicitly mentions this particular attack in section 2.1.1: “Authorization servers MUST mitigate PKCE Downgrade Attacks by ensuring that a token request containing a codeverifier parameter is accepted only if a codechallenge parameter was present in the authorization request, see Section 4.8.2 for details.”

For more information

If you have any questions or comments about this advisory:

References

Affected packages

Go / goauthentik.io

Package

Name
goauthentik.io
View open source insights on deps.dev
Purl
pkg:golang/goauthentik.io

Affected ranges

Type
SEMVER
Events
Introduced
2023.10.0
Fixed
2023.10.7

Database specific

{
    "last_known_affected_version_range": "<= 2023.10.6"
}

Go / goauthentik.io

Package

Name
goauthentik.io
View open source insights on deps.dev
Purl
pkg:golang/goauthentik.io

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2023.8.7

Database specific

{
    "last_known_affected_version_range": "<= 2023.8.6"
}