GHSA-mxvc-fwgx-j778

Suggest an improvement
Source
https://github.com/advisories/GHSA-mxvc-fwgx-j778
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-mxvc-fwgx-j778/GHSA-mxvc-fwgx-j778.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mxvc-fwgx-j778
Aliases
Published
2022-07-15T15:37:39Z
Modified
2024-02-16T08:19:02.888033Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Whoogle Search Cross-site Scripting via string parameter
Details

The package whoogle-search before version 0.7.2 is vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the errormessage that is then rendered in the error.html template, using the flask.rendertemplate function. However, the error_message is rendered using the | safe filter, meaning the user input is not escaped.

References

Affected packages

PyPI / whoogle-search

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.2

Affected versions

0.*

0.1.0
0.1.3
0.1.4
0.2.0
0.2.1
0.3.0
0.3.1
0.3.2
0.4.0
0.4.1
0.5.0
0.5.1
0.5.2
0.5.3
0.5.4
0.6.0
0.7.0
0.7.1