GHSA-p3g4-9xfv-wq9v

Suggest an improvement
Source
https://github.com/advisories/GHSA-p3g4-9xfv-wq9v
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-p3g4-9xfv-wq9v/GHSA-p3g4-9xfv-wq9v.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p3g4-9xfv-wq9v
Aliases
  • CVE-2018-1000058
Published
2022-05-14T03:40:05Z
Modified
2024-02-18T05:31:22.378604Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Arbitrary code execution due to incomplete sandbox protection in Pipeline: Supporting APIs Plugin
Details

Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.

References

Affected packages

Maven / org.jenkins-ci.plugins.workflow:workflow-support

Package

Name
org.jenkins-ci.plugins.workflow:workflow-support
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins.workflow/workflow-support

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.18

Affected versions

0.*

0.1-beta-1
0.1-beta-2
0.1-beta-3
0.1-beta-4
0.1-beta-5
0.1-beta-6
0.1-beta-7
0.1-beta-8

1.*

1.0-beta-1
1.0
1.1
1.2
1.3
1.4
1.4.1
1.4.2
1.4.3-beta-1
1.4.3
1.5
1.6-alpha-1
1.6
1.7-alpha-1
1.7
1.8
1.9-beta-1
1.9
1.10-beta-1
1.10
1.10.1
1.11-beta-1
1.11-beta-2
1.11-beta-3
1.11-beta-4
1.11
1.12-beta-1
1.12-beta-2
1.12-beta-3
1.12
1.13
1.14-beta-1
1.14
1.14.1-beta-1
1.14.1
1.14.2
1.15-beta-1
1.15

2.*

2.0
2.1
2.2
2.3
2.4
2.5
2.6
2.8
2.9
2.10
2.11
2.12
2.13
2.14
2.15
2.16
2.17
2.17-durability-beta-1
2.17-durability-beta-2
2.17-durability-beta-3

Database specific

{
    "last_known_affected_version_range": "<= 2.17"
}