GHSA-p3ph-6245-4wfc

Suggest an improvement
Source
https://github.com/advisories/GHSA-p3ph-6245-4wfc
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/12/GHSA-p3ph-6245-4wfc/GHSA-p3ph-6245-4wfc.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p3ph-6245-4wfc
Aliases
Published
2023-12-14T18:30:21Z
Modified
2024-02-16T08:21:02.873157Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site Scripting in JFinalcms
Details

JFinalcms 5.0.0 is vulnerable to Cross Site Scripting (XSS).

References

Affected packages

Maven / com.jfinal:jfinal

Package

Name
com.jfinal:jfinal
View open source insights on deps.dev
Purl
pkg:maven/com.jfinal/jfinal

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
5.0.0

Affected versions

1.*

1.4
1.4.0
1.5
1.6
1.8
1.9

2.*

2.0
2.1
2.2

3.*

3.0
3.1
3.2
3.3
3.4
3.5
3.6
3.7
3.8

4.*

4.0
4.1
4.2
4.3
4.4
4.5
4.6
4.7
4.8
4.9
4.9.01
4.9.02
4.9.03
4.9.04
4.9.05
4.9.06
4.9.07
4.9.08
4.9.09
4.9.10
4.9.11
4.9.12
4.9.13
4.9.14
4.9.15
4.9.16
4.9.17
4.9.18
4.9.19
4.9.20
4.9.21
4.9.22
4.9.23

5.*

5.0.0