GHSA-p3xv-97g8-4wmj

Suggest an improvement
Source
https://github.com/advisories/GHSA-p3xv-97g8-4wmj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-p3xv-97g8-4wmj/GHSA-p3xv-97g8-4wmj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p3xv-97g8-4wmj
Aliases
Published
2022-05-17T04:52:37Z
Modified
2024-02-16T08:20:11.259618Z
Summary
Python Swift client is vulnerable to Missing SSL Certificate Check
Details

The OpenStack Python client library for Swift (python-swiftclient) from 1.0 before 2.0.2 does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.

References

Affected packages

PyPI / python-swiftclient

Package

Name
python-swiftclient
View open source insights on deps.dev
Purl
pkg:pypi/python-swiftclient

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.0
Fixed
2.0.2

Affected versions

1.*

1.0
1.1.1
1.2.0
1.3.0
1.4.0
1.5.0
1.6.0
1.7.0
1.8.0
1.9.0

2.*

2.0
2.0.1

Database specific

{
    "last_known_affected_version_range": "<= 1.9.0"
}