GHSA-p632-5w74-x8xx

Suggest an improvement
Source
https://github.com/advisories/GHSA-p632-5w74-x8xx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-p632-5w74-x8xx/GHSA-p632-5w74-x8xx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p632-5w74-x8xx
Aliases
Published
2022-05-17T03:12:55Z
Modified
2024-02-16T08:06:56.282124Z
Summary
phpMyAdmin Cross-site scripting (XSS) vulnerability via pageNumber value
Details

Cross-site scripting (XSS) vulnerability in libraries/schema/Export_Relation_Schema.class.php in phpMyAdmin 3.5.x before 3.5.8.2 and 4.0.x before 4.0.4.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted pageNumber value to schema_export.php.

References

Affected packages

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5
Fixed
3.5.8.2

Packagist / phpmyadmin/phpmyadmin

Package

Name
phpmyadmin/phpmyadmin
Purl
pkg:composer/phpmyadmin/phpmyadmin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.0
Fixed
4.0.4.2

Affected versions

4.*

4.0.0
4.0.1
4.0.2
4.0.3
4.0.4
4.0.4.1