GHSA-p6xq-9h8r-v544

Suggest an improvement
Source
https://github.com/advisories/GHSA-p6xq-9h8r-v544
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/02/GHSA-p6xq-9h8r-v544/GHSA-p6xq-9h8r-v544.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p6xq-9h8r-v544
Aliases
Published
2023-02-10T15:30:28Z
Modified
2024-02-16T08:06:50.959592Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
CodenameOne Pending Intent vulnerability
Details

A vulnerability was found in CodenameOne 7.0.70. The manipulation leads to use of implicit intent for sensitive communication. It is possible to launch the attack remotely. Upgrading to version 7.0.71 is able to address this issue. The name of the patch is dad49c9ef26a598619fc48d2697151a02987d478. It is recommended to upgrade the affected component.

References

Affected packages

Maven / com.codenameone:codenameone-core

Package

Name
com.codenameone:codenameone-core
View open source insights on deps.dev
Purl
pkg:maven/com.codenameone/codenameone-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.71

Affected versions

v7.*

v7.0.81

7.*

7.0.8-b1
7.0.8-b2
7.0.8-b3
7.0.8-b4
7.0.8-b5
7.0.8-b6
7.0.8-b7
7.0.9
7.0.10
7.0.11
7.0.12
7.0.13
7.0.16
7.0.17
7.0.18
7.0.19
7.0.20
7.0.21
7.0.22
7.0.23
7.0.25
7.0.26
7.0.27
7.0.28
7.0.29
7.0.30
7.0.31
7.0.32
7.0.33
7.0.34
7.0.35
7.0.36
7.0.37
7.0.38
7.0.39
7.0.40
7.0.41
7.0.42
7.0.43
7.0.44
7.0.45
7.0.46
7.0.47
7.0.48
7.0.49
7.0.50
7.0.51
7.0.54
7.0.55
7.0.56
7.0.57
7.0.58
7.0.60
7.0.61
7.0.62
7.0.63
7.0.64
7.0.69