GHSA-p8ww-vv84-c2rm

Suggest an improvement
Source
https://github.com/advisories/GHSA-p8ww-vv84-c2rm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2018/10/GHSA-p8ww-vv84-c2rm/GHSA-p8ww-vv84-c2rm.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p8ww-vv84-c2rm
Aliases
  • CVE-2015-2912
Published
2018-10-18T17:41:13Z
Modified
2023-11-08T03:57:52.416988Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
OrientDB-Server vulnerable to Cross-Site Request Forgery
Details

The JSONP endpoint in the Studio component in OrientDB Server Community Edition before 2.0.15 and 2.1.x before 2.1.1 does not properly restrict callback values, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks, and obtain sensitive information, via a crafted HTTP request.

References

Affected packages

Maven / com.orientechnologies:orientdb-studio

Package

Name
com.orientechnologies:orientdb-studio
View open source insights on deps.dev
Purl
pkg:maven/com.orientechnologies/orientdb-studio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.15

Maven / com.orientechnologies:orientdb-studio

Package

Name
com.orientechnologies:orientdb-studio
View open source insights on deps.dev
Purl
pkg:maven/com.orientechnologies/orientdb-studio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.1.0
Fixed
2.1.1

Affected versions

2.*

2.1.0