GHSA-p99h-pfg6-qrfg

Suggest an improvement
Source
https://github.com/advisories/GHSA-p99h-pfg6-qrfg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/12/GHSA-p99h-pfg6-qrfg/GHSA-p99h-pfg6-qrfg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-p99h-pfg6-qrfg
Aliases
Published
2023-12-12T03:31:45Z
Modified
2024-02-16T08:09:06.944477Z
Severity
  • 9.1 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
Privilege escalation in sap-xssec
Details

SAP BTP Security Services Integration Library ([Python] sap-xssec) - versions < 4.1.0, allow under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application.

References

Affected packages

PyPI / sap-xssec

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.1.0

Affected versions

1.*

1.1.8

2.*

2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.0.10
2.0.11
2.0.12
2.1.0

3.*

3.0.0
3.1.0
3.2.0
3.3.0

4.*

4.0.0
4.0.1